Tomatoville® Gardening Forums


Notices

General information and discussion about cultivating herbs.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old October 9, 2015   #1
robneal17
Tomatovillian™
 
Join Date: Sep 2015
Location: Massachusetts
Posts: 4
Default oregano plant died

Hello everyone
I started a bunch of oregano plants from seeds at the start of the summer. some of them flourished, some did okay. I took a flourishing one, put it in a different pot and brought it to school with me. The leavers began turning brown so i repotted it, but the plant still slowly died. I put it out of it's misery today.

why did this happen? i see it happening on the other potted oregano plants too, just not as fast. Is it due to too much water? I notice the soil stays wet for longer in an indoor condition because I have standard lamps instead of sunlight which also gives radiant heat to evaporate water.

I also had a parsley plant spontaneously succumb to root rot yesterday, over the period of one, maybe two nighnts indoors. I'm definately thinking im overwatering given a standard potting soil mix with no provision for the lack of sun energy.

Thoughts?
robneal17 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:41 PM.


★ Tomatoville® is a registered trademark of Commerce Holdings, LLC ★ All Content ©2017 Commerce Holdings, LLC ★